Online Training Center System Requirements

To use the NAFCU Online Training Center, you must have the following system requirements.

For Live and On-Demand Webinars

Windows minimum system requirements:

  • Intel Pentium II processor or Celeron or AMD processor, 400mhzWindows 95/98/2000/NT System.
  • Macintosh and Unix are not supported
  • 128K RAM
  • 16-bit sound card and speakers
  • 65,000-color video display card
  • Broadband Internet connection that supports at least 350K throughout
  • Web browser (see specific browser info above); cookies enabled
  • Windows Media Player 6.4 or later
  • Pop-up blocker turned off
  • If you are behind a corporate firewall or proxy server, you may need to have it configured to pass the webinar video stream.

Your mobile device must meet the following minimum requirements:

iPad® requirements
• iPad (3rd generation and higher), iPad Air, iPad Air 2, or iPad Mini (1st generation and higher)
• iOS 8.0 or later
• Apple Mobile SafariTM
• Wi-Fi or cellular data connection (3G or higher)

iPhone®/iPod® requirements
• iPhone 5 and higher, iPod Touch (5th generation or higher)
• iOS 8.0 or later
• Apple Mobile Safari
• Mediasite Mobile App (free download available from the Apple app store; not required for iOS 10+)
• Wi-Fi or cellular data connection (3G or higher)

AndroidTM
• Android 4.4 or later
• Android browser
• Wi-Fi or cellular data connection (3G or higher)

Microsoft Surface and Windows RT tablets
• Windows 10, 8.1 or 8
• Microsoft Edge or Internet Explorer 10.0 or later
• Wi-Fi or cellular data connection (3G or higher)

Blackberry requirements (on-demand MP4 playback only)
• Blackberry OS 10.0 or later
• PlayBooksT for QNX devices
• Blackberry browser
• Wi-Fi or cellular data connection (3G or higher)

Technical Requirements and Recommendations

To solve any technical streaming issues, please advise your IT department to go through this checklist:

  • Some network administrators block streaming media at the firewall. If you are unable to view streaming video, you may need to notify your network/IT administrator.
  • The following firewall ports may need to be opened/configured for proper webinar viewing: TCP/80, TCP/443, TCP/554, and UDP/554.
  • Packet shapers, VPN’s, and/or proxy servers can also cause adverse effects on live streaming. These should be bypassed if possible; at very least streaming traffic should be allowed through. Additionally, streaming may be blocked if firewalls deny the RTSP protocol.
  • Some network security policies restrict or filter content (web filtering) based on site URL (this is sometimes referred to as “white listing” a domain).
  • If there are intrusion detection/intrusion prevention systems (IDS/IPS) in place, they could adversely affect streaming. You may experience very high latency times, delays in video, audio out of sync, instability in the stream, or a complete lack of being able to watch. Streaming traffic should be allowed to bypass when possible.
  • Some firewalls and/or Internet proxies may also require content to be categorized (uncategorized content is often blocked by default). Webinar content will be served from akamai.net, akamaihd.net, lambdacdn.net, and edgecastcdn.net domains, so traffic from these domains need to be allowed.

Testing Your System

Live webinar participants are strongly encouraged to test their system at least 24 hours prior to the webcast. Please make sure that your computer system meets the basic requirements listed above.

Please use the following link to test your specific systems' hardware/software compliance.

You can test your device's audio and video by viewing the following live webinar test.

You can test your device's audio and video by viewing the following on-demand webinar test.

If you require additional technical assistance, please email mdalusung@nafcu.org 

For Self-paced Modules

(Including modules in the New Staff Online Training, Board of Directors Online Training Subscription, and the Management and Leadership Series)

All you need is a computer and an Internet connection. The faster your Internet connection, the faster the modules will load. You'll need Flash Player 6.0.79 or later, free to download at www.adobe.com/go/getflash, Acrobat Reader, free to download at http://get.adobe.com/reader/ and one of the following browsers:

Windows: Internet Explorer 10 or higher, Firefox 1.x and later, Safari 3, Google Chrome, Opera 9.5

Macintosh: Firefox 1.x and later, Safari 3 Linux: Firefox 1.x or later